Unibank™ smartphone minimum requirements

The Unibank app requires iOS version 10 or higher, or Android version 5.0 (Lollipop) or higher.

If you still need help, please use our contact form and a member of our team will get back to you as soon as possible.

Unibank logo

Your privacy

We and our partners use technologies, such as cookies, and process personal data, such as IP addresses and cookie identifiers, to personalise ads and content based on your interests, measure the performance of ads and content, and derive insights about the audiences who saw ads and content. Click accept an move on to consent to the use of this technology and the processing of your personal data for these purposes.